
NEAMS Workbench and IES Holistic Energy Resource 
Optimization Network (HERON)

Rob Lefebvre, Paul TalbotHands on Working Lunch

5 April 2023

https://ies.inl.gov/SitePages/Home.aspx


https://ies.inl.govhttps://ies.inl.gov

Purpose

• Context:
• The NEAMS Workbench integration into FORCE is a new effort
• Problem inputs and workflows are varied and can be complex
• Workbench has features to help users

• Key goals:
• Simplify problem input and workflow 
• Expose you to working examples of Workbench FORCE features as 

available in current releases
• Open communication channels and obtain user feedback
• Ultimately, improve problem input preparation, execution, and results 

visualization
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Outline

• Review Workbench + HERON requirements and setup
• Review the XML to EDDI input conversion step

• Lightweight input format that preserves data without extra syntax
• Explore Workbench
• Conduct job launch
• Visualize results and explore visualization settings
• Discuss
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Requirements Review

• NEAMS Workbench 5.2
• Available for download at https://code.ornl.gov/neams-

workbench/downloads/

• Recent HERON release
• Initial Workbench integration occurred March 10th 2023 via changeset 

daca1335

• Local installation or INL NCRC Access (hpcondemand.inl.gov)

• Conversion of HERON native XML input to EDDI-formatted input
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• NEAMS Workbench is available on INL’s Nuclear Computation 
Resource Center (NCRC)

• Use default settings
• Ensure 5.2 is selected

Start Workbench



https://ies.inl.gov

Start the NEAMS Workbench

• Help documentation will display during the first 
startup

• Help documentation is accessible via Help>Help 
Documentation
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Configure HERON in Workbench
• Configuring an application active in Workbench is only required once
• 2 primary routes for configuring HERON active in Workbench

1. INL’s NCRC preconfigured ‘localhost’ HERON activation
1. Click File > Localhosts…
2. Select the available application table row containing NCRCHERON and click activate
3. Wait for activation to conclude as indicated by the message Process finished with 0 

return code
4. HERON is now activated

2. Your own machine’s installation
1. Click File > Configurations…
2. Click Add…
3. Select Heron from the drop-down and click OK
4. Update Executable property Value to be path to raven/plugins/HERON/heron and use 

enter key to capture the field – this may pause momentarily as the HERON grammar 
information is loaded

5. HERON is now activated 
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Review XML to EDDI

• What is EDDI and why?
• Extra Definition Driven Input (EDDI) is a lightweight open-source input syntax 

that is supported in Workbench
• It is used as an integration prototype to achieve the following:

1. Enable Workbench integrators to programmatically survey existing HERON inputs
2. Serve as a design iteration to the question ‘is there a better user input format?’

• EDDI preserves all data structure but avoids the bothersome XML syntax
• Conversion script is available in Workbench

• Takes XML file and emits EDDI-formatted equivalent
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XML to EDDI | Execution

Example execution converting existing XML-formatted input to EDDI
Linux and Mac OS invocation (terminal)
Workbench/rte/entry.sh Workbench/rte/util/xml2eddi.py path/to/heron_input.xml > path/to/heron_input.heron

Windows invocation (CMD)
Workbench/rte/entry.bat Workbench/rte/util/xml2eddi.py path/to/heron_input.xml > path/to/heron_input.heron

- Workbench: Path to the Workbench installation
- path/to/heron_input.xml: Path to favorite HERON input
- > path/to/heron_input.heron: Output redirection to EDDI-formatted input (The file to be opened in Workbench) 

Note: ‘heron’ extension is the default recognized HERON input in Workbench
Note: if performing the conversion on NCRC you will want to copy the HERON input directory to a location to 
which you can write
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XML2EDDI Conversion

• Go to Command line and convert XML to EDDI-formatted 
*.heron file

• On INL HPC you will need to copy test files to a writable location
• Run the following commands in a HPC Terminal

cp -r /apps/local/raven/raven_heron_20230327/plugins/HERON/tests/ ~/Downloads/heron_tests/

/apps/local/neams/Workbench-5.2.0/rte/entry.sh /apps/local/neams/Workbench-5.2.0/rte/util/xml2eddi.py 
~/Downloads/heron_tests/workshop/simple/heron_input.xml > 
~/Downloads/heron_tests/workshop/simple/heron_input.heron

• Open the *.heron input file in Workbench
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NEAMS Workbench Document Navigation

• Hierarchical Listing of Document 
• Quick Navigation to input
• Plot creation

• Filter 
• Regular expression-based item filtering

• Open Associated Files
• Lists files with matching extension-less filename
• Streamlines opening associated files

• Dockable
• Dock to main NEAMS Workbench application
• Float in separate window
• Hide completely
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NEAMS Workbench Input Editor Components
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Application Syntax Highlighting

• File extensions for which to automatically associate
• Whitespace delimited list of file extensions for which to automatically associate 

the grammar rules.
• Syntax highlights for each grammar pattern

• Edit Foreground and background color
• Indicate bold and/or italic font face



https://ies.inl.govhttps://ies.inl.gov

Input Autocompletion Overview
• What is it? 

• Autocompletion is the ability for Workbench to 
generate parts of the input on demand

• Why is it needed? 
• Autocompletion listings communicate to the user 

what input parts are available for insertion which 
accelerates input creation

• Where is it available?
• Everywhere, unless all valid input has been 

specified
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Output Text File Viewing

• Easy to access from the Input 
file’s list of associated files 
popup context menu.

• Output file Can be drag-n-
dropped onto NEAMS 
Workbench from a file browser 

• Any application file with an 
extension, (*.inp,*.out, etc.) can 
be dropped onto NEAMS 
Workbench

• Open directory assists in 
identifying files for drag-n-drop
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Miscellaneous Features

• Column select/edit 
• via ALT+left click+mouse drag key and mouse combo

• Go to definition – allows quick navigation to input components 
definition via a right click popup context menu.

• E.g., anywhere an identifier is used to reference another input component.
• Math evaluator

• Ability to evaluate selected text as a math expression – replaces selection 
with expression’s result.

• Comment toggle 
• Ability to comment/uncomment selected lines

• Indent/unindent
• Ability to indent/unindent selected lines

• Auto saves – automatic back up to inputname.wb.autosave.
• File exists only while there are unsaved document changes

• Features illustrated on following slides
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Miscellaneous : Column Selection/Edit

Formatting related text into aligned columns allows for faster recognition and column-
wise text operations. 
• NEAMS Workbench provides column selection via ALT+MOUSE SELECTION.
• With column selection made, any edits are made to all columns for each row. 

• E.g., Update all isotope weight percent values to have a decimal digit.
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Miscellaneous : Go To Definition

The ‘Go To Definition’ feature is intended to facilitate the user in quickly navigating to the component being referencing. 
• New users can discover input component relationships. 
• Experienced users can have their navigation accelerated, especially in larger inputs.

• Referenced Geometry Surface identifiers goes to the surface definition.
• Accessible via right clicking an input component
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Miscellaneous : Math Evaluations

• Mitigates typographical errors

• Encourages documentation of engineering specifications that 
require conversion

• Full complement of math functions available : 
• +,-,*,/,^,sqrt, cos, sin, root, abs, min, max, avg, sum, mul, floor, ceil, exp, log, logn, log10, hyp, if, 

clamp, inrange, sign, deg2rad, tan, equal, acos, asin, atan, cosh, tanh, sec, csc, cot, sinh, round, 
roundn, d2g, g2d, r2d

• Evaluation occurs on selected text
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Miscellaneous : Comment Toggle

Comment toggling allows users to quickly comment or uncomment pieces of input.
• Allows comment creation
• Mitigates user needing to recall what a comment looks like
• Assists in input development iterations
• CMD+/ on OS X and CTRL+/ on Windows and Linux
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Miscellaneous : Input Indent/Unindent

• Hierarchical input (Application > Block > Record) can be depicted using levels of indentation 
• Input indent and unindent facilitates quick formatting to visually depict hierarchy 
• Indentation operates on selected text, 4 spaces per indent/unindent
• In inputs without terminators, indentation is used to prioritize autocompletion suggestions
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Miscellaneous : File Autosaves

Any file NEAMS Workbench edits - currently only text files - are 
immediately backed up to a filename.wb.autosave. In the scenario 
that the NEAMS Workbench or computer crashes the autosave file 
will persist. 

• Upon NEAMS Workbench restart, reloading the original file will 
check for filename.wb.autosave and load this instead, mitigating 
any lost progress

• A save of the file will remove the autosave
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Workbench HERON Input

• Demonstrate HERON input features in Workbench
• Launch HERON input

• Workbench’s HERON runtime converts *.heron to native HERON XML 
and executes HERON and RAVEN as needed

• *.heron becomes *.heron.xml and can be reviewed for completeness
• Open opt_soln_0.csv and plot results
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General Plot Overview

• Interactive and configurable plot rendering
• Plot data table displays graph data.

• Allows row, column, and table copy to clipboard.



https://ies.inl.govhttps://ies.inl.gov

Plot Controls
NEAMS Workbench plots consist of graph, bars, or color 
maps, which can be manipulated as follows.
• Select graph via left click in plot or legend.

• Remove or move selection via context menu
• Zooming is performed via the mouse scroll action.

• Zoom in by scrolling up.
• Zoom out by scrolling down.

• Reset to original via context menu Fit graphs.
• Panning is performed via a click and drag.

• Pan right by left clicking and dragging left.
• Pan up by left clicking and dragging down.

• Save Plot as 
• PDF (includes scalable vector graphics SVG),
• PNG and JPG image format
• Interactive Scale Plot Format (SPF)

• Plot attributes (color, style, etc.) can be 
changed via context menu Plot options.

• Plot Legend can be drug to 9 positions 
via left-click and drag.
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Plot Controls : Plot Options  
• Chart – Allows changing the plot title and title visibility.
• Legend – Allows changing the legend’s font and visibility.
• Axis – Allows changing axis visibility, label text, label text 

font, axis scale, axis range, axis grid, tick label font and tick 
text attributes (rotation, precision, etc.).

• Graphs – Allows changing graph name, line style, line 
color, line weight, scatter style, scatter size, pen style, 
adaptive sampling*, errors bars.

• Bars – Allows changing bar graph name.
• Color Map – Allows changing color map graph name and 

color gradient.

* adaptive sampling – conducts intelligent sampling of the data points providing significant speed up when many data points are involved. Default is on.
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Processor Generated Result Plots
• Automates data plot generation

• Streamlines typical excel spreadsheet workflow of extracting data to 
charts.

• User-extensible
• Can execute user specified logic
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Processor Generated Results Plots

Clicking the Optimization_Trajectory will generate plot tabs
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Processor Generated Results Plots

Tabs can be rearranged for broader viewing experience of results
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Questions & Discussion

Special thanks to Mark Baird (ORNL) and Brandon Biggs (INL) 
for facilitating the use and demonstration of the NEAMS 
Workbench and HERON on INL’s NCRC

Reminder: integration effort is new. User input and feedback is 
valuable. 

30


